[Mysql]Error:extension is deprecated and will be removed in the future: use mysqli or PDO instead

PHP/Error

PHP Deprecated:  mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in C:\Users\xxx.php on line 6


上記のエラーは、非承認の関数を使ったときのエラー。

PHP5.5から、mysql_connect() を利用しただけで発生する。
2014-09-12 21:13 コメント
已邀请:

ベストアンサー

0

iQi - 面白いアプリを開発中

{ 賛成 }:

下記、みつの方法、いずれこのエラーを修正できますが、エラー内容通り、ソースコードを修正すべきである。
1.php.iniファイルを修正する

display_errors = On → display_errors = Off


2.Deprecatedのエラーを吐かないようにするといい。

error_reporting(E_ALL ^ E_DEPRECATED);


3.ソースコードを修正する。

<?php
$link = mysql_connect('localhost', 'user', 'password');
mysql_select_db('dbname', $link);


<?php
$link = mysqli_connect('localhost', 'user', 'password', 'dbname');

<?php
mysql_query('CREATE TEMPORARY TABLE `table`', $link);

mysqli_query($link, 'CREATE TEMPORARY TABLE `table`');
2014-09-12 21:20 コメント

ログインまたは登録してから回答してください

Lubo
Lubo

PHP言語が得意です

@ステータス

  • 更新: 2014-09-12 21:20
  • 閲覧: 1889
  • フォロー: 2
EXIT フルスクリーンモード 回答